Internet Issues

Major incident Denton ISD Website Canvas HAC TAC Classlink SSO Microsoft MS Teams Microsoft 365 Google Suite for EDU Canvas
2021-12-15 09:56 CDT · 1 hour, 42 minutes, 11 seconds

Updates

Resolved

This issue is now resolved.

December 15, 2021 · 11:39 CDT
Issue

The service provider is working to restore normal service as quickly as possible.

December 15, 2021 · 09:58 CDT

← Back