Regional internet outage causing some services to fail.

Major incident Classlink SSO
2021-08-31 18:51 CDT · 12 hours, 10 minutes, 13 seconds

Updates

Resolved

The issues affecting the Classlink SSO have been resolved. This service is now operational.

September 1, 2021 · 07:01 CDT
Monitoring

A regional internet outage affecting Denton ISD has caused some services, including the Classlink SSO to be down. This page will be updated as soon as the service is available again.

August 31, 2021 · 18:53 CDT

← Back