Classlink SSO is down

Major incident Classlink SSO
2021-08-10 11:20 CDT · 18 minutes, 49 seconds

Updates

Resolved

Classlink has resolved their issue and the SSO is operational again.

August 10, 2021 · 11:38 CDT
Issue

The Classlink SSO is experiencing issues after initial login. The Technology Division is aware and working with Classlink for a timely resolution. This page will be updated when the incident is resolved. Thank you.

August 10, 2021 · 11:21 CDT

← Back